Unanswered question

SMS doesn't work between 2 fizz users?

I can send SMS to people who are *not* FIZZ users (fido, videotron etc) without any problems, and so can my daughter (who is on my fizz plan), but when we text each other (SMS), it doesn't work. If we want to text, one of us has to be connected to WiFI. If we are both on data, or just on regular plan (unlimited text), it doesn't work. But she can text other people and so can I.

Is there a known problem related to fizz users texting to each other?

Catherine
Catherine

Catherine

User level
Level
0
41 / 100
points

Answers

Mike
Mike

Mike

User level
Level
4
5000 / 5000
points

You have an iPhone the problem is with your iMessage, try to disable it.

https://support.apple.com/fr-ca/HT204065

Catherine
Catherine

Catherine

User level
Level
0
41 / 100
points

I have tried with iMessage enabled and disabled, and so has she (we tried every combinaison - believe me!) but it doesn't seem to be the problem... And the fact we can both text to non-fizz users - weather they are iPhone uses or not- might indicate that the problem is with fizz?

No. Did you check in your IPhone if you have the email of your daughter? Cancel it and just keep her phone number to try. And check if you have block her phone number..just in case.

Mike
Mike

Mike

User level
Level
4
5000 / 5000
points

When you send the message is blue?
Blue is meaning that the message go throw data
Green with the SMS

Mike
Mike

Mike

User level
Level
4
5000 / 5000
points

What colour is the bubble?
https://support.apple.com/en-us/HT207006

Blue meaning that the message goes throw data, since you do not have data using the WIFI
Green with the SMS

Matthew
Matthew

Matthew

User level
Level
3
3760 / 5000
points

Can you try starting a conversation from her phone number? The fact that you need to be on wifi does suggest that you phone is forcing the conversation to iMessage over text. As Mike asked, if the messages are always blue then you are using iMessage. If you use just her phone number it should allow you send as text (if the box in the picture where it says send as SMS is checked green).

Catherine
Catherine

Catherine

User level
Level
0
41 / 100
points

She is not blocked because I receive her texts without problems if I'm on WiFI (and she on data) or, if I'm on data, and she is on WiFi. It's really when we are both without WiFi that it doesn't work!!

The bubble is green, I have her phone number and she has mine, and we both erased our emails. I guess I could completely erase our contacts and re-enter them. I'm also going to try my sim card in another phone.

Matthew
Matthew

Matthew

User level
Level
3
3760 / 5000
points

Hi Catherine,
Do you have this "Send as SMS" check off in green?

Catherine
Catherine

Catherine

User level
Level
0
41 / 100
points

Yes! We both have the "send as sms" option checked. And we know it works because we can text her father and all our friends without any problems. We tried to close+open our phones, and we have updated them to the latest iOS. She has a very recent iPhone, mine is 2 years old.

Matthew
Matthew

Matthew

User level
Level
3
3760 / 5000
points

I am not sure what the problem would be. I just tried with our two iPhones off data and off wifi - the texts went through, but the first text I had to resend we are both Fizz users. Under the message setting "send&Receive" your number is listed as an address? Sorry, I am not sure what else to try. Good luck!

Catherine
Catherine

Catherine

User level
Level
0
41 / 100
points

I finally solved the problem!
I went to General - Reset and selected: "Reset network settings" and it worked!!!
The reason why I only had this issue with one person remains a mystery, but everything is normal now.
Thank you for all your suggestions!

Matthew
Matthew

Matthew

User level
Level
3
3760 / 5000
points

Wow! Yay! Thanks for posting what worked in the end. Happy texting!

Juan
Juan

Juan

User level
Level
1
737 / 750
points

Weird. What’s your phone type?

Martha
Martha

Martha

User level
Level
2
899 / 2000
points

It should work! It’s weird!!