Answered question

My travel add-on to Brazil is not working, even with the data-roaming activated on the phone. What can I do?

I bought a Brazil travel add-on before I left and now that I am in Brazil I can't get my phone to work. Data-roaming is activated on the phone. But it only connects to the internet if there is a free Wi-Fi connection, so I can't use any mobile data. Which means that I can't use Google maps to get around the country... How can I get my travel add-on mobile data to work?

I've got a Samsung Galaxy J1(6) phone, if that matters. Thanks for the help!

(I left this question a couple of minutes ago but mistakenly selected the Best Answer button before solving the problem. Duh!)

David
David

David

User level
Level
0
23 / 100
points

You should check your APN settings.

APN | Network Settings | Fizz

Fizz APN settings are:

APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl

Go to mobile networks settings, create a new APN and enter the information above.
Then you can delete all the others and let just this you created.

Restart your phone after.

Se precisar de comunicar em português, pode me enviar msg privada que eu o ajudo remotamente. Boa viagem!

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Your phone must  be compatible with the Band B3 or B7 for the LTE
try to enable the 3G

If you have the exact version of your J1 will be great to see wich band has
https://www.frequencycheck.com/carrier-compatibility/5QDvcKn/samsung-sm-j106b-ds-galaxy-j1-mini-prime-2016-duos/nextel-brazil
 
Did you put the carrier selection to automatic?
Did you already try to restart the phone, sometime helps

To contact the support you need to go to this page https://fizz.ca/en/contact-us, Fizz push you to find your solution, therefore, you need to search in the solution hub to your solution and only after 10 seconds that you are in a solution page Fizz will give you the chat bubble.

CHAT

  • Go to this page https://fizz.ca/en/faq/im-unable-log-my-fizz-account-what-do-i-do, if you are not connect login
  • The business hours: every day from 8 a.m. to 9 p.m. (EST).
  • Wait 5 seconds for the bubble icon to appear at the bottom right of the browser and click on the icon to chat with support. Try a different browser if you have issues getting the bubble to appear.

If the chat bubble does not appear, this means that the number of sessions waiting for our answers surpasses our processing capacity. If that happens, send us a private message via Facebook Messenger or Twitter.

FACEBOOK

Your can also send a message via facebook messanger https://facebook.com/fizzca and click send a message (this is a bit slower)

CONTACT FORM

You can also fill a contact form from your account Once logged in, from the account panel go to My Profile → Contact Form (the subject are limited) and fill out the form and someone will email you back.

David
David

David

User level
Level
0
23 / 100
points

Hi Mike,
the exact model is SM-J120W. The carrier selection was previously on automatic, and the phone automatically chose Vivo as the carrier.

I am going to try Thiago's advice now and see if I can get it working.

Thanks so much for your help!

David
David

David

User level
Level
0
23 / 100
points

Thiago, it looks like your advice worked! Obrigado amigo!!!