Answered question

can not subscribe to internet service

after i entered the credit card number it just wont let me advance to the next step

Pulasthi
Pulasthi

Pulasthi

User level
Level
0
1 / 100
point

You might want to clear browser cache/cookies and try again in incognito mode.

Check that your credit card is accepted by Fizz and that your address matches exactly the address on your credit card statement from your bank: https://fizz.ca/en/faq/what-payment-methods-can-i-use

If all else fails, you can contact Fizz support.

You can send a message by facebook https://facebook.com/fizzca

 

Or you can use Fizz chat. Make sure that:

  • You're logged into your Fizz account.
  • You're active on a help page such as https://fizz.ca/en/contact-us
  • Simply click on the chat bubble that appears at the bottom on the right.
  • You're within the business hours: Monday to Friday from 8 a.m. to 9 p.m. (EST), weekends and holidays from 10 a.m. to 6 p.m. (EST).
  • You have disabled any ad blockers in your browser.

If the chat bubble does not appear, this means that the number of sessions waiting for our answers surpasses our processing capacity. If that happens, send us a private message via Facebook Messenger or Twitter.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

As Fizzy indicated it seems a browser problem. I had a similar problem with Firefox, and I turn on/off a parameter (privacy). Then it worked fine.

Make sure your billing address matches.

Otherwise, contact Fizz Support as indicated by Fizzy.

Good luck

Whizz
Whizz

Whizz

User level
Level
4
5000 / 5000
points
Team

Hi Pulasthi,

In order to be able to help you further, I'm kindly asking you to contact us in private by chat or Facebook messenger. You can find the info for reaching us on the following link: https://fizz.ca/en/contact-us.

In the meantime, I advice you to try again after you delete your browser cache and cookies. You can also test with a different browser or from another device. You could also try with your browser in incognito mode.

Have a great day!
Radu