Answered question

I cant connect to data even though i bought a travel add on

I bought the travel add on for the correct country. I cant connect to a network or use data. My phone is telling me that my sim card is not compatible with the mobile network.

Emilie
Emilie

Emilie

User level
Level
0
4 / 100
points

Hi, please make sure you APN settings are correct, something else that I noticed is that you have "Automatically select network turned off, i'd probably recommend turning that on since it might be trying to connect to the Fido, Bell, Rogers or any other carrier networks.

https://fizz.ca/en/faq/what-are-fizz-network-settings-apn

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Like @Chris says, you need to have correct APN settings.

 

Also what phone are you using?

 

Your phone needs to be compatible with Fizz for data : It must have band 4 which is required for LTE.

https://fizz.ca/en/faq/compatible-devices
Mobile data: Your device must have dual-frequency support for 1700/2100 MHz (also called AWS or band IV)

irene
irene

irene

User level
Level
4
5000 / 5000
points

Activate automatic select network on your phone. I saw only now that Chris already gave this advice

Hi Emilie,

If you're still having this issue, in order to be able to help you further, I'm kindly asking you to contact us in private by chat or Facebook messenger. You can find the info for reaching us on the following link: https://fizz.ca/en/contact-us.

Have a great day!
Radu