Answered question

Roaming sign within the covered area

Hi, just switched to Fizz. Does anyone have any ideas why do I see roaming sign on my Home screen (just in case, it's Galaxy J1 Ace) even though I am within the covered area in Montreal?
Thank you in advance!

Irina
Irina

Irina

User level
Level
0
57 / 100
points

Hello Irina Grinchenko,

Our costumer service is 100% digital so you can contact us only by chat or by private message via Facebook Messenger, you can also check the following link: "https://fizz.ca/en/contact-us";.

Have a lovely day!

Radu

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

MT
MT

MT

User level
Level
4
5000 / 5000
points

Do you see Fizz network or Fizz Ext ( roaming) ?
If you see Fizz then you're not in roaming.
If you see Fizz Ext then you're in roaming and there is a few possibilities :
1) Your phone is not compatible with Fizz
2) Fizz network is not available in your area (temporarily or permanently)
.
.
Did you configure APN parameters on your phone to see ?

MT
MT

MT

User level
Level
4
5000 / 5000
points

You can verify your phone compatibility with Fizz using this https://fizz.ca/en/faq/compatible-devices

Looking around, I don't think that the Galaxy J1 Ace is fully compatible avec the frequencies that Fizz uses, which is why you'd be on roaming even in Montreal. If you look at the available signals, is FIZZ amoung them or only Fizz EXT?

MT
MT

MT

User level
Level
4
5000 / 5000
points

One thing to remember : Fizz would end your service if you'll be using Fizz Ext over 3 consecutive months.
So make sure that you're using Fizz network rather than Fizz Ext network.

The phone should be compatible as per GSMARENA
Network Technology
GSM / HSPA / LTE
2G bands GSM 850 / 900 / 1800 / 1900 - SIM 1 & SIM 2 (dual-SIM model only)
3G bands HSDPA 850 / 900 / 2100 - J111F
HSDPA 850 / 900 / 1700(AWS) / 1900 / 2100 - J110M
HSDPA 850 / 900 / 2100 - J110F
HSDPA 850 / 1900 / 2100 - J110L
4G bands LTE band 1(2100), 3(1800), 5(850), 7(2600), 8(900), 20(800) - J110F
LTE band 1(2100), 2(1900), 3(1800), 4(1700/2100), 5(850), 7(2600), 17(700), 28(700) - J110M
LTE band 1(2100), 3(1800), 5(850), 7(2600), 8(900), 20(800), 40(2300) - J110G, J111F
Speed HSPA 21.1/5.76 Mbps, LTE Cat4 150/50 Mbps
GPRS Yes
EDGE Yes

Make sure your provider default settings is set to Automatic and that carrier setting should show Fizz 34.1 or Fizz 35.0

Chizz :))

Michel
Michel

Michel

User level
Level
1
436 / 750
points

FWIW, my phone is almost always "roaming" on the Fizz network. Once it a while, my phone displays '4G-LTE' but most of the time it displays '4G-Roaming'.

I'm in Ottawa and work in Gatineau.

Irina
Irina

Irina

User level
Level
0
57 / 100
points

Thank you all for you replies.They somewhat clarify the situation.

*I only see Fizz Ext in the list of my available networks. However, I haven't yet received an email from Fizz regarding the termination of the service or they only send it after 3 consecutive months of roaming? In this case, I don't mind adding Canada to my plan to keep the Fizz service..

**The phone was bought in Europe, but was perfectly working with Fido for the last year and a half. After checking https://fizz.ca/en/faq/compatible-devices and Gsmarena it seems that in theory Galaxy J1 Ace should be compatible with the Fizz network..

***Btw, does anyone know the number to contact Fizz call-center?

Thanks again!