Answered question

works on Iphone 5c?

i'm reading about not working on iphone 5. but the iphone 5s? i know iphone 5 had problemas with compatibility on 4g/lte because was more limited on frequency bands. and i know iphone 5c was not limited with that...

Andre
Andre

Andre

User level
Level
0
1 / 100
point
Pat
Pat

Pat

User level
Level
2
874 / 2000
points

The issue is the IOS. You need IOS 12.1 for it to work on iphone and iphone 5s is the oldest model that supports IOS 12.1.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers