Answered question

Why is my internet so sluggish? I have a 60 plan but speed test says 35?

I changed Chanel from default but still bugs



User level
1 / 100

Hi Daniele
Sorry you are having internet issues.
Please unplug the Fizz modem from the wall outlet for 2 minutes. Then restart it and try a speedtest.

Try to connect to your modem with ethernet cable or with the Fizz app, this will give you an accurate measure for the speed test.
If the problem continues, you can try factory reset of the modem by pressing and holding down the small button behind the modem for 10+ seconds with a sharp object like paper clip. If you doing this you need to reconfigure the modem.
Keep in mind that the maximum speed of your plan is the total bandwidth speed shared among all users in your home. 
Does the speed issue happen with wifi only or also with ethernet connection? 
You already try but try an other channel

If the problem is happening with wifi only, you may benefit from disabling auto channel selection in your modem admin settings, and selecting a specific channel. You can find the channel which is least congested by using a smart phone and downloading a WiFi analyzer app, which will show you the channel usages of nearby devices. 
To change the channels: 
1- Connect to your Wi-Fi network.  
2- Open the browser on any device, and enter the address 
3- Log in using these credentials: 

  • Username: cusadmin 
  • Password: (Enter your password, the one you chose when you initially configured your network) 

  • 4- In the green bar, select Wireless. 
    5- Then select: General settings → 5 GHz and/or 2.4 GHz →Wireless channel 
    6- Select a different channel. 
    If there is no improvement, you can contact customer support by chat at anytime 24/7: 
    1- Click on this link:
    2- The green chat bubble should appear after a few seconds in the bottom right corner. Click on it
    3- Select chat

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Well, not much to add to Mike’s answer.
Yesterday I had some speed problems too. I just turned the modem off/on and it started to work again