Answered question

How do I get someone to help me with my slow connection?

Randomly, my internet connection gets slow to the point where it is practically unusable. I've tried to get help with this in the past, but I was told the problem was on my end and to try a bunch of stuff I'd already tried. Usually, the sped comes back after a few minutes or after I reboot the modem. Right now, my internet speed is less than 1mbps and has been for about an hour, even after multiple modem reboots. Here's how I'm set up:

  • Fizz modem in Bridge mode
  • Google mesh router for wireless
  • Linksys 24-port switch for wired devices

Here's what I've tried:

  • Restarted the router via software interface
  • Restarted the modem via software interface
  • Unplugged router and all access points and left them unplugged while I unplugged the modem
  • Plugged modem, waited for all lights to turn on, then plugged in router and access points
  • Connected laptop directly to modem

The last time this happened and I contacted Fizz, they told me to perform a factory reset on my modem. It did nothing, so I did not do it this time.

At this point, I know my in-house equipment is not faulty, as my speed is still slow while directly connected to the modem. I think there might be a problem with my connection to the node, but I don't know how to confirm it.

Can someone from Fizz see if my signal fluctuated unusually in the past 12 hours or so? Other users I've discussed with in other forums have said they had similar issues that were traced to intermittent physical issues.

Thank you!

Domenico,
usually the Whizz has to contact them to further help you.
The chat is available, but probably they will start answering starting for 8am, then in ~30 mins

under your modem when not configured in bridge modem, you should be able to see the status
Status > DOCSIS WAN (this is the original firmware)

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Domenico,
you are right only fizz can monitor your signal to confirm if the problem is in their side.
Can you check if some of your neighbour that use the internet cable have the same problem?

Thanks, Mike.
My upstairs tenant uses Bell and my neighbour whose house is connected to mine (and whose bundle of cables comes from the same place as mine) also used to use Bell, though there are new owners since July and I haven't asked them which provider they use.
I know that only Fizz can check my signal, but I'm also pretty sure they monitor these forums. The chat was unavailable at this time (and I don't have Facebook/Instagram), and I wanted to post while the issue was occurring so I could document my troubleshooting steps in real time.

I've been dealing with this problem for quite a while, though it has never lasted this long (still doesn't get higher than 2mbps, as of this writing).
So, I know how to log into the modem, even while in Bridge mode (for me, it was accessible at 192.168.100.1, even though that is not the subnet assigned by my router).
However, since my WAN is disabled, I can't see the heading you've mentioned. I can see, though, that the firmware listed is 2.0.10.43b8. this is the same firmware version the modem had when I first reported the issue over a year ago. Is this what you meant by "original firmware"? Not sure I understood the statement.

Oh, one other thing I forgot to mention is that my upload speed stays normal at 20mbps. It's my download speed that drops to below 1mbps, when it should be 120mbps.

The speed is now back to normal, after over 2 hours of degraded service. Still, I need this fixed as I can't have this happen while I'm working from home.