Answered question

International calls not working?

I have paid for the international calls to New Zealand addon, however when I try to call it says my plan doesnt support it. It has worked fine in the past and I can call NZ when I add funds to my wallet.

Jonathan
Jonathan

Jonathan

User level
Level
0
1 / 100
point

Hi Jonathan

Please verify on your Fizz account that the correct add-on has been purchased and is active.
Also try restarting your phone.

Note that if you made a plan change to add an international calling option to your plan, the change will be effective only after your plan renews.

If the problem continues, you can contact customer support by chat at any time 24/7:

1- Connect to your Fizz account by clicking « Login » in the top right corner at fizz.ca
2- Any ad blockers in your browser should be disabled.
3- Open a Fizz help page like this one: https://fizz.ca/en/faq/how-do-i-make-an-international-cal...
4- The green chat bubble should appear after a few seconds in the bottom right corner.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Sergii
Sergii

Sergii

User level
Level
1
213 / 750
points

Hello Jonathan!
First of all, you need to open your Fizz account - My plans - Manage plan. Please chose Advanced Parameters there and look at the checkbox "No international calls". You should turn it OFF. I attached a screenshot of the parameters for you.
Secondly, you must have active add-ons or funds in the Wallet.

Whizz
Whizz

Whizz

User level
Level
4
5000 / 5000
points
Team

Hello Jonathan,

I have verified and see that you've managed to contact us on Chat. My colleague escalated a ticket to our technical team for further verification. As soon as we will have an answer from them you will be notified by e-mail address.

Please reach us back if you have any other questions. Here you can find how to contact us: https://fizz.ca/en/contact-us

Have a wonderful day!

Adelina