Answered question

Internet (60 Mbps download) showing as being at half speed. Normal?

Other than this PC, no other devices should be connected to my Internet at present, yet the download speed is half of what I'm paying for. I disconnect the modem for a few minutes to reboot it, but the speeds are only a bit better (see attached).
Over the past month my wife has complained (numerous times) that the Internet isn't stable enough for her teleconferences. She's often the only one using our Internet, hence even at my currently "low speeds" should be enough for her work, or so I would have thought, no?
I'm changing my plan from the 60/10 to 120/20 but I'm not sure if their is something else that could explain the problem. Thoughts?

Simon
Simon

Simon

User level
Level
1
457 / 750
points

Hi Simon

Try to connected the computer with the ethernet cable or with the Fizz's app, this will give you the real speed

Have you tried restarting your modem?

You may benefit from disabling auto channel selection in your modem admin settings, and selecting a specific channel. You can find which channel is least congested by using a smart phone and downloading a WiFi analyzer app, which will show you the channels of nearby devices.

1- Connect to your Wi-Fi network.
2- Open the browser on any device, and enter the address 192.168.0.1
3- Log in using these credentials:
Username: cusadmin
Password: (Enter your password, the one you chose when you initially configured your network)

4- In the green bar, select Wireless.
5- Then select: General settings → 5 GHz and/or 2.4 GHz → Wireless channel

6- Select a different channel.

Choose a channel that’s far from the one your modem currently uses, and test it for a few days to see whether things improve or not. Ex. Go from channel 6 to 11. Or, from channel 6 to 1.

Your Fizz Wi-Fi modem uses by default the to frequency band steering technology. When this function is disabled, the Wi-Fi modem will display two (2) frequency bands, 2.4 GHz and 5 GHz.

1. Log in at: 192.168.0.1 from the web browser of any device.

2. Log in using the following information:

Username: cusadmin
Password: xxxxxxxx (Password you chose during initial setup)
3. Go to the next section to apply changes: Wireless → General Settings → 5GHz → Band Steering (Disable)

Si rien fonctionne contactez le support

You can contact customer support by chat, from 8 AM to 9 PM every day:

1- Connect to your Fizz account by clicking « Login » in the top right corner at fizz.ca
2- Any ad blockers in your browser should be disabled.
3- Click on this link: https://fizz.ca/en/faq/my-wi-fi-network-cutting-how-do-i-...
4- The green chat bubble should appear after a few seconds in the bottom right corner.

Your can also send a message via facebook messanger https://facebook.com/fizzca and click send a message (this is a bit slower)

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Simon
Simon

Simon

User level
Level
1
457 / 750
points

Oops! I just realized that my speeds are OK when the PC is connected with the ethernet cable (it had disconnected).
I'll check my wife's PC in case it's a similar "problem". ;)

Minh
Minh

Minh

User level
Level
1
185 / 750
points

if you still need help, you can ask fizz on facebook messenger, they always respond!

Minh
Minh

Minh

User level
Level
1
185 / 750
points

seems like you already got the answer, but if u still need help you can contact fizz on facebook!