Answered question

Why am I having lag in my video calls?

I just switched internet providers from Techsavvy where I had 20 mgs download and never had issues with my video calls. I have just signed up with Fizz with 60 mgs download and my video calls lag, drop etc.

I’ve already spoken with tech support and followed the steps but the problem consists. Is anyone else having this problem and what is the solution? Debating cancelling already after 10 days of being signed up.

Tyson
Tyson

Tyson

User level
Level
0
27 / 100
points
Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Hi Tyson

Does the problem happen with wifi only? Or also when you connect a device directly to the modem via ethernet cable?

If the problem happens only with wifi, you can use a wifi analyzer app to check which wifi channels/signals are available in your area for less interference. You can also try putting the Fizz modem in bridge mode and using your own router.

If problem continues, you can contact customer support by chat, from 8 AM to 9 PM every day:

1- Connect to your Fizz account by clicking « Login » in the top right corner at fizz.ca
2- Any ad blockers in your browser should be disabled.
3- Open a Fizz help page like this one: https://fizz.ca/en/faq/my-modem-connected-cable-my-connec...
4- The green chat bubble should appear after a few seconds in the bottom right corner.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Whizz
Whizz

Whizz

User level
Level
4
5000 / 5000
points
Team

Hy Tyson,
I understand and I'm sorry for the inconvenience.

I checked on your account and on your connection signals where I can see that they are off from the optimal parameters.
There is also no incident or maintenance work being performed in the area that could've caused the disruption.

Would you kindly please unplug the coaxial cable from the coaxial outlet and the modem respectively, wait for about 30 seconds, then plug it back in the outlet first and then in the modem, then restart it?

Also, please perform a factory reset of the modem by using a sharp object to press on the small button in the orifice behind the modem for 15 to 20 seconds, then let the modem reboot itself and test the connection.

Following this, please change the connection bandwidth from 2.4GHZ to 5GHZ as shown here below:
The modification of this option is possible thanks to the mobile application Fizz Wi-Fi:
Choose: ''My Wi-Fi''
Select your Wi-Fi network
Select: ''Advanced Settings''
Band Steering ''On/Off''

This change can also be applied through the Wi-Fi modem user interface:
1. Log in at:192.168.0.1 from the web browser of any device.
2. Log in using the following information:
Username: cusadmin
Password: xxxxxxxx (Password you chose during initial setup)
3. Go to the next section to apply changes:
Wireless → General Settings → 5GHz → Band Steering (Disable)

Thank you very much for your understanding.
Andrei

Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Hi Tyson

Whizz Andrei has given some great suggestions to improve your Fizz home internet experience.
Let us know if they help.

If the problem is happening with WIFI, there is another option available for you. When you were with TekSavvy, did you have your own modem and router? If you prefer, you can put the Fizz modem in bridge mode and use your own router for your wifi.
https://fizz.ca/en/faq/how-can-i-use-my-own-wi-fi-router-...

Tyson
Tyson

Tyson

User level
Level
0
27 / 100
points

I have followed the steps from Whizz and there is no change. My internet is horrible. All video calls lag and drop. Not happy at all with this service.

Mike
Mike

Mike

User level
Level
4
5000 / 5000
points

Tyson you must contact the support
Since the Whizz wrote

"signals where I can see that they are off from the optimal parameters."

Then they should do something about that since you do not have a good signal from their cable.