Answered question

Why can't I send/receive SMS although I have them in my plan?

This is ridiculous. Several weeks without being able to send/receive sms on my phone altought I have indeed included sms in my account. I even tried switching to a brand new phone, to no avail. Contacted Fizz already and they fixed it for 2 weeks than the issue came back and no feedbac, no solutions from them. This is absurd.

annie
annie

annie

User level
Level
1
102 / 750
points
Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Hi Annie

Sorry you are having phone issues.

If Fizz was able to fix the issue I would follow up with them again.

In case you haven't already seen this, here is a link to their troubleshooting guide: https://fizz.ca/en/faq/i-cant-send-or-receive-text-messages

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Carlo
Carlo

Carlo

User level
Level
3
2689 / 5000
points

Annie, what did Fizz fix exactly? Is it something only under their control or they modified something in your phone to hat you can recreate ( there may have been an update in your phone or your new phone doesn't have these settings). The SMS are available with specific APN settings described in under vanigh's file.

Samuel
Samuel

Samuel

User level
Level
1
405 / 750
points

Hi annie.
Sorry to hear that.
Try changing the “network selection” in the settings of your phone, Maybe your phone is set in a different region. You best bet is to contact fizz support again.
Have a great evening.

Manny
Manny

Manny

User level
Level
1
628 / 750
points

Are you sure it's worth everyone or just some carriers?

Mihai
Mihai

Mihai

User level
Level
2
1044 / 2000
points

Hi Annie,

To receive text messages is not necessary to have them in plan, everybody will receive SMS free of charge. So, your problem is not linked to SMS plan. Hope you already restarted the phone.
You have to use the default SMS app.
Also, if is a multimedia message check the APN settings:
APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl
For details see here: https://fizz.ca/en/faq/what-are-fizz-network-settings-apn
Contact again Fizz for further help.