Answered question

WIFI connection issue with RCA Smart TV

My RCA TV is not connecting to my home WIFI anymore, but it was working perfectly fine until last week.
1. did the factory reset - RCA TV
2. tried connecting multiple times to FIZZ - connection failed
3. When I try to connect RCA with my iPhone hotspot, it is recognizing it as WIFI and is getting connected.
4. Changed the WIFI password, that doesn;t work either.

So when my iphone hotspot was connected thats when I know it is not TV , its something in the settings of internet connection.

Any suggestions will be appreciated
Thanks in advance

Pavleen
Pavleen

Pavleen

User level
Level
0
13 / 100
points
Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Hi Pavleen

Check the specs of your RCA TV. Is it able to connect to both 2.4 GHz and 5 GHz networks?

And how far is the TV located from the Fizz modem?

I suspect that the 2.4 GHz WIFI band will work better with your RCA TV.

If you have problems with some devices connecting you can disable the automatic band steering on the Fizz modem. This will create two networks one 5GHz and one 2.4GHz. If the 5 GHz band is not needed, you may also choose to disable it.
See step 2 here: https://fizz.ca/en/faq/what-are-wi-fi-technologies-used-fizz

If the problem continues, please feel free to post your updates here.

If you want to contact customer service by chat, they are available from 8 AM to 9 PM every day:

1- Connect to your Fizz account (if you have more than one, connect to the one that has the problem) by clicking « Login » in the top right corner at fizz.ca
2- Click on this link: https://fizz.ca/en/faq/my-wi-fi-network-not-available-cer...
3- The green chat bubble should appear after a few seconds in the bottom right corner.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Fizzy
Fizzy

Fizzy

User level
Level
4
5000 / 5000
points

Pavleen,

Here's something quick you can try. If you have setup the proper WIFI setting on the TV, try unplugging the TV's AC plug. Wait one minute and then plug it back in.

Pavleen
Pavleen

Pavleen

User level
Level
0
13 / 100
points

Hi,

Thank you for help, I tried disabling band and unplugging TV last week and today as well nothing helped. At the end, I just ended up resetting my modem to factory settings and voila connection was enabled :)

Thank you and have a great day