Answered question

can't call a 11 digit phone number,

can't call a 11 digit phone number, msg recording says " your current plan doesn't allow this call, please sign into your account and adjust it" after signing in where do i adjust it?

Abe
Abe

Abe

User level
Level
0
13 / 100
points

Sorry You have the international calls disabled

You also need to activate the International calls option of your plan. To do so:

  • Go to My Plans in your Fizz account.
  • If there is more than one plan on your account, scroll to the plan you wish to change.
  • Click on Manage and choose Advanced parameters.
  • Next to No International calls, slide the radio button to Off.
  • International Calls Option
  • .
    Source: https://fizz.ca/en/faq/how-do-i-make-an-international-cal...

    edited, my first answer was wrong 13:24

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

What plan coverage do you have?

What are the first 4 digits you are try to call?

Make sure the number you are calling is correct. Try manually entering the digits into your dialer, then press talk/send.

If you do not have money in your wallet or add-on, your plan will permit calls within your coverage area.

Abe
Abe

Abe

User level
Level
0
13 / 100
points

FOLLOWING IS THE BEST ANSWER RECEIVED FROM MIKE!
" Try to add 1 or +1 it worked "
added 1 and it works!!
FYI calling a 514 area code number