Answered question

How to bypass low quality images in MMS using stock google Messages app by force enabling RCS?

I've seen a few post about RCS after trying to figure why I was limited to low resolution in MMS since swinching to Fizz from Rogers yesterday. I decided to test and figure a fix. Anyone who want to enable high resolution can do so either by using 3rd party SMS app or by enabling RCS in Google Messages app. Steps described below in answer!

Louis-Phillippe
Louis-Phillippe

Louis-Phillippe

User level
Level
1
258 / 750
points

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Jimmy
Jimmy

Jimmy

User level
Level
3
3010 / 5000
points

Great to know, thank you !

Louis-Phillippe
Louis-Phillippe

Louis-Phillippe

User level
Level
1
258 / 750
points

Sorry for the delay, it seems my reply was moderated for a while.

First, here's a few test I have done to try and figure out what was happening. If you only want the fix, scroll down until step 1.

I've tried changing Google official messages app settings for maximum MMS size but found out it's hard coded in the program itself. Reaching out to support of Google Messages, they confirmed it cannot be changed by the user. They instead verify the carrier code and the max MMS size the carrier reported to them to set the limit internally.

Since Rogers supports RCS, it could be either that MMS were previously going thru RCS (no size limit) but I recall having full resolution animated gif before RCS so I think they simply report a higher maximum to google.

Now, since I couldn't change this limit on Messages, I wanted to test if Fizz actually has a low limit. I took the first MMS app I found and set a no limit on it, on both my and my wife's phone. The results were the following:

- Using Google message on rogers between us was giving full size animated gif.
- Using Google message on Fizz give compressed images.
- Using 3rd party MMS app with no size limit sending from Fizz to Google messages on Fizz gave full size anim gif.

This leads me to think that Fizz incorrectly report their MMS limit to Google and that they could easily fix it. Otherwise, maybe they simply try to trick user into using low limit MMS to use less bandwidth. 


Now, regarding RCS. Videotron still hasn't enabled it as of today. Google did launch a service to bypass the carrier but it doesn't seem to work by itself and need a small hand. I managed to enable it on my Pixel 2 XL (a bit of work since I didn't knew how) as well as on my daughter Essential phone pretty quickly thereafter.

If anyone is interested in the fix to have RCS working, here are the steps I used (found parts of them on google, I don't claim to be the author of the app that helped it work)

STEPS to enable RCS:

1 - First open Google Messages app (or install it if you don't have it, others SMS app won't support RCS in Fizz atm). In the top right corner, tap the 3 dots to bring up the menu and then open Settings.


2 - Click on Chat features. It first told me service was not available because carrier doesn't support it. If that's your case, follow to next step. If it shows as "verifying your phone number", jump to step 7.

3 - Open Google play and download the app Activity Launcher from Adam Szalkowski : 
https://play.google.com/store/apps/details?id=de.szalkowski.activitylauncher

4 - Start Activity Launcher, accept the disclaimer and scroll down to "Messages" (They are in alphabetical order). Click on it for this application settings to show as a list below it. Click on "Set RCS Flags".

5 - In this net setting page, click on the first option called "ACS Url" and choose the last option which reads up as :  " http://rcs-acs-prod-us.sandbox.google.com/ "  and then click on apply (you might need to hit the "back" key to minimize your keyboard, I had to do so on both my devices).

6 - Open Messages app again, click the 3 dot at the top right of the screen and open Settings as previously. Chat features should now show something new, either connected or trying to verify phone number. If it shows connected, congratulation, you are done! Otherwise, follow to step 7 for a quick fix.

7 - Click on Chat features. Set your phone number and hit verify. I've had this step bug on my a few times. If it will not verify, the way I found to fix this was the following :

8 - Get back to Messages app main screen. On the top right corner near the 3 dots, there should now be a star with an ! inside it. Click on it. It'll ask for your phone number. Enter it and hit verify. The app might connect by itself or it might ask for a verification number. If a number is ask, you should receive it by SMS within a few seconds of hitting verify. Once received, enter the verification number. It might tell you there is an error but ignore it.

9 - Close the app and restart it. If everything went as it did for me, chat features should now be enabled! To verify, open Settings again and click on Chat features. It should now show as Connected.

Enjoy the high resolution MMS at fast speed, no more waiting 2 minutes for it to send/be received. 

I must warn you though, MMS will now be sent thru interet data. If you are not connected to some wifi networks, it will use your monthly data. If you want to avoid taking too much data, I'd suggest limiting it to 10mb. It's about 20fold better quality than base mms, yet not enough to blow your limit and also stop error such as burning your month of data because you mistakenly send a 500mb video mms.

Thanks to the community for the questions asked in my other thread that lead me to finding a solution.

Olivier
Olivier

Olivier

User level
Level
4
5000 / 5000
points

LP is right

Vicky
Vicky

Vicky

User level
Level
0
13 / 100
points

Thank you, it worked and helped me and my husband!

Post of the month!

Louis
Louis

Louis

User level
Level
0
14 / 100
points

Awesome! Exactly what I was looking for.

Nini
Nini

Nini

User level
Level
4
5000 / 5000
points

Thank you for sharing! Those kind of posts on the forum are really the ones the most helpful!

Louis-Phillippe
Louis-Phillippe

Louis-Phillippe

User level
Level
1
258 / 750
points

Thanks guy, it is good to know my post is helpful to some of you!