Answered question

No Fizz LTE accessable in US

I have a Fizz account which is a data plan (2Gb) for Canada and US . I came down on dec 3 to US and could not access internet through LTE . My acces was ok in Quebec . I did change my plan in October to include US coverage. I had a note from FIZZ on my phone saying that my plan didn't allow me to access LTE service in US and I need to add money to my account . Please let know what is wrong .

poupou47
poupou47

poupou47

User level
Level
0
2 / 100
points
MichelP
MichelP

MichelP

User level
Level
4
5000 / 5000
points

Did you activate data roaming on your phone? Try to find manually a LTE , or 3g network available where you are.

Did you try to put off your phone somes minutes and open it after.
Or, try to put on your phone the airplane mode around 15secondes.

If nothing is working, Please chat on line with them (from 8h00 to 21h00).

Open a session online , go to your account, type:

https://fizz.ca/en/contact-us

When you see the green chat bubble down the right to the page, click on it.
Your chat session is on.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

kk
kk

kk

User level
Level
2
939 / 2000
points

usually you need to activate roaming, put your phone in plane mode and activate networks again.
if no LTE, try to turn off LTE in cellular settings.

Make sure your plan change in October worked. Some people had problem to change their plan successfully.

 

If you have Canda and USA coverage and you are receiving that text to add money to your account, you should chat with Fizz support.

Del8ed
Del8ed

Del8ed

User level
Level
3
2913 / 5000
points

Are you sure at least that your cellphone is compatible with the LTE frequency used by the US provider you're connected on?

I recently came back from Orlando. The Fizz service was working well.

 

Sometimes you have to restart your phone to get it going.

Or manually choose your network if needed.

 

If your phone works in Canada, it should work in USA as well.

Please provide us with an update.

maybe its the provider you are connected to
i know T-MO uses 1700/2100 frequency (band 4)
just like fizz does for data
if your roaming is on
it should work

has your issue been resolved
if so what was the cause