Answered question

South Korea?

I have a mobile plan addon for Asia, and I am currently in South Korea, but the data roaming is NOT working at all.
It automatically connects to SK Telecom and I do have roaming data enabled.
Please advise

Gerard
Gerard

Gerard

User level
Level
0
3 / 100
points
Whizz
Whizz

Whizz

User level
Level
4
5000 / 5000
points
Team

Hello Gerard,

In order to be able to help you, please contact us via Facebook Messenger or Live Chat. On the following link you will find information regarding how you can do that: https://fizz.ca/en/contact-us .

Thank you very much for your understanding.
Have a good one!
-Bogdan

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Fist make sure that roaming is enabled then make sure that the APN is correct. You can also try to manually connect to different networks.
Hope this helps.

Andréanne
Andréanne

Andréanne

User level
Level
1
427 / 750
points

You should contact fizz directly

Simon
Simon

Simon

User level
Level
0
82 / 100
points

Try to manually connect to a provider and activate the 3G/4g

Wissam
Wissam

Wissam

User level
Level
0
96 / 100
points

As you can see, the travel Add-on for Zone Asia/Oceania covers several countries.

So the same travel add-on will give you mobile data in both Korea and Hong Kong.

Remember to enable roaming on your phone and you may need to manually select FIZZ-EXT carrier in some countries if auto network isn't working.