Answered question

fizz account web setting

I cannot change plan communication preference from email to text on setting section in my account.
see an attached image for detail.
any suggestions? thank you.

I made the changes for account and mobile communication preferences and saved them, but when I logged back, the changes were gone, and the communication preference was back to email.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

I am able to modify the communication preference from email to text for the account and for the mobile plan, but not for the internet plan.
What is even more weird - I've received notifications as per my data usage by text whereas my preference has been set to email.
Looks like there are some bugs to be fixed.
My suggestion - try to do it in another browser.

I'm experiencing some slowness in getting into my account. Maybe they are doing some maintenance that won't allow you to make these changes? I was finally able to get to my settings and I am able to make changes.

Try again? And if it still isn't working, contact support.

Have you tried using a different browser on your computer?

Or try clearing browser cache and retry using incognito/private mode?

 

On my Fizz account, I am able to click on ">" to see my preference details. I can change any of the preferences,