Answered question

Block display my number on outgoing call?

I had to block my number for a call and I used a 'vertical carrier code' *67 or similar. According to google this was supposed to be for the one call but now my number always shows as private and I can't seem to find a way to undo it. Fizz don't seem to know. Help?!

Michael
Michael

Michael

User level
Level
0
32 / 100
points

Try number 2 here:

  1. Dial *08 to turn off display of your Caller ID information on all outgoing calls.
  2. Dial *06 to turn on display of your Caller ID information on all outgoing calls.
  3. Dial *67 and then enter the phone number you want to call to turn off display of your Caller ID information for just that one call.

 

If problem persists, what phone are you using?

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Michael
Michael

Michael

User level
Level
0
32 / 100
points

Tried *67 but problem persists.
It may have been a slightly longer code with 4 or 5 characters.
Phone is XiaoMi A2 lite.
Thanks!

Michael
Michael

Michael

User level
Level
0
32 / 100
points

Sorry I meant *06. Problem persists.
I put *06 and then hit dial and it said my plan did not permit this call

Go with Julien's suggestion. You can select "show number" or "Network Default".

If problem persists, can you try your SIM on another phone?

If both phones show the same issue with this SIM only, then you should contact Fizz via Facebook Messenger or Live Chat.

GOAT
GOAT

GOAT

User level
Level
3
2297 / 5000
points

"Show number" should definitely work. Very strange that it defaulted to private number.

Michael
Michael

Michael

User level
Level
0
32 / 100
points

SOLVED!
I do not have the path given by Julien.
But I do have it enabled via Phone > Settings > Caller ID & spam

And I just found the solution !!! via Phone > Settings > Calling Accounts > Fizz > GSM call settings > Additional call settings > Caller ID

Thanks everyone for your help!

This looks to be an issue related to your phone brand. By using the *67 code, it should block your number for just that one call. For your phone, it just changes your setting to block your number until you change it back. Glad you found the solution!