Answered question

Few issues regarding address book, MMS and US number?

Hey guys,
Hopefully you all could help me. I'm having a few issues with my new Fizz account. They're minor issues but I'd like to have them resolved. I have a Samsung S8.

1) When I open my address book, under the "Me" contact, where it's supposed to show my phone number, it shows my referral's number. Not mine.

2) Can't receive any MMS messages. I can receive text ones okay, but no MMS.

3) My 438 Montreal area code shows as a US location. When I call someone else, on their caller ID it says "United States." When a Montrealer calls me from their landline, it prompts the message "This is a long distance number, please press 1 if you want to continue."

Caitlynn
Caitlynn

Caitlynn

User level
Level
0
72 / 100
points
Caitlynn
Caitlynn

Caitlynn

User level
Level
0
72 / 100
points

Scratch that, the US issue isn't fixed yet. I'll have to speak to Fizz.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

MT
MT

MT

User level
Level
4
5000 / 5000
points

1) Address book on your phone is managed by you not Fizz.
.
2) MMS : in order to user MMS you need data in your plan. If you do have data, did you configure APN parameters (https://fizz.ca/en/faq/what-are-fizz-network-settings-apn)
.
3) For this issue you need to contact Fizz. You can "chat" with Fizz by opening a help page(exemple https://fizz.ca/en/faq/im-unable-log-my-fizz-account-what...)

Caitlynn
Caitlynn

Caitlynn

User level
Level
0
72 / 100
points

The address book was never touched, i haven't added any contacts. On the S8 once i inserted the SIM card it automatically configured my number for me and it put it as my referral's number. It's not something I could change.

However, I just downloaded the APN parameters and it seems to have fixed all 3 issues. Very interesting! Thanks for your help!

redhead
redhead

redhead

User level
Level
3
2359 / 5000
points

Someone else (Alain) had similar issue. Here is what he found out:
I just found in my setting there is SERVER and there is MULTIMEDIA SERVER . So I wrote the information in the wrong box for the APN setting . now its working correctly
(Source: https://community.fizz.ca/questions/1918022-mms-data-problem)

Ed
Ed

Ed

User level
Level
3
4042 / 5000
points

It might be just a display issue. I also have a display issue on my account. You need to go to your account and carefully check if all the information reflects your subscription. A chat with Fizz will fix display issues only on your next payment cycle.