Answered question

Do I need to configure outgoing SMTP server for sending email in Fizz data plan?

If yes, what is the outgunning SMTP server address for Fizz data plan. I can't send email from the Fizz data plan!!

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

M is right, this has nothing to do with Fizz. You have to set up your email app correctly and then it will work with whatever data service you connect to.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

MT
MT

MT

User level
Level
4
5000 / 5000
points

You need to configure the smtp server as specified by your mail service provider.
.
This is not Fizz specific but your mail service provider

ThomasK
ThomasK

ThomasK

User level
Level
4
5000 / 5000
points

Just use an e-mail app, most will detect right setting for common e-mails such as gmail,yahoo and outlook e-mail.

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

@M, When I was using Bell internet connection, I used their outgoing SMTP server address. If I am using some other internet provider, I have to use theirs. In that scenario, I could send the email. But now I can not send any email from that. It going to stuck with outbox and says failed.

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

@Tom, there is no concept of outgoing SMTP server for email providers that you have suggested. I am talking about official emails, which need to be configured in an e-mail app with outgoing SMTP server address.

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

Looks fishy here, I have wrote the comments and those comments are removed by the moderator. I want to know any solution exists for this?

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

Please check below link which says to use internet provider's SMTP server settings for outgoing email.

https://aits.encs.concordia.ca/aits/public/helpdesk/clien...

MT
MT

MT

User level
Level
4
5000 / 5000
points

Try smtp.fizz.com to see if it works ( default port is 25 for most stmp server )

Shreyamsha that advice is out of date. It used to be the case that SMTP connections were anonymous and Internet providers would block port 25 to force customers to use their own SMTP server as an anti-spam measure. But these days they don't do that anymore and people usually use blacklisting, logins, and encrypted connections to deal with spam instead. Fizz is definitely not blocking SMTP connections, so as has been noted several times you don't need to use Fizz's SMTP server and I doubt they're even running one. What you should do is send mail using the SMTP server run by your email provider (e.g., Google or Hotmail, or your work). They will likely require you to authenticate using your email address and password to send messages, probably (and preferably) along with SSL encryption for the connection. Regardless, it's time for you to find out what their SMTP server's address is and use it for the SMTP server settings in you email app.

Just to add, you're incorrect that the email services Tom listed have no concept of an outbound SMTP connection. All email is sent via SMTP and this has always been the case (using any relevant definition of always). Including Gmail, yahoo, and outlook (the former Hotmail not the application).

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

M, I tried to use smtp.fizz.com as SMTP server, but it says couldn't establish connection with the server.

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

I tried to use smtp.fizz.com as SMTP server, but it says it couldn't establish a connection

kamurb
kamurb

kamurb

User level
Level
1
513 / 750
points

I have an email address of concordia and I have configured the SMTP server with theirs. It works either way, sending and receiving emails, from that email provided I connected to the university's WiFi. If I disconnect the WiFi and connect Fizz data, then it does not work.

Before, I was using Bell home internet, and I was using their outgoing SMTP server address, then the same concordia email was working either way, sending and receiving emails, from that concordia email address.

Can any one here point out the problem?