Unanswered question

No service in ottawa? Airport 1bar/no signal

I just switched over from Freedom, which has pretty good coverage at work(Ottawa Airport). I get 1 bar or no bars of 4G when I am here. Even when I leave the airport it doesn't give me good service. Constantly losing service and gaining service. Ran a speed test and here are the results
Ping:300ms
Jitter 336ms
Download 3.62
Upload 0.01

Tyler
Tyler

Tyler

User level
Level
0
22 / 100
points

Answers

Jana
Jana

Jana

User level
Level
1
318 / 750
points

Device?
Working fine for me Galaxy Note9 and S9+

Tyler
Tyler

Tyler

User level
Level
0
22 / 100
points

I'm using an lg v20 h915

KB
KB

KB

User level
Level
0
97 / 100
points

I work all around the city Pixel 2 XL and no service issues so far.

Anne
Anne

Anne

User level
Level
4
5000 / 5000
points

Mine works fine, I guess it's our phone side problem. Or lack some bands.

Tyler
Tyler

Tyler

User level
Level
0
22 / 100
points

Well it seems like the other phone is doing the same thing. Both phones have correct bands for the frequency. I'll try contacting fizz to see if they can replace my Sim card maybe it's an issue there.

I got 3.6 down and 2.4 up this morning at the airport with my other phone

David
David

David

User level
Level
2
1138 / 2000
points

Happened to go to the Ottawa airport this morning. Very strong signal as you can see in the screenshot. This is on AWS-1 band LTE. So if you don't have a great signal there then maybe your phone has an issue.