Answered question

My data does not work. Why?

I did the Apn setup and received the 2 texts to modify the setup and installed them. Still no data nor MMS. I have a Galaxy S4 if that can help

Gilles
Gilles

Gilles

User level
Level
0
54 / 100
points

Sorry but I just notice the model.
I'm afraid it could be a compatibility issue here
Galaxy S4 does not support LTE Band 4

@Gilles M.
Fizz support don't get involve here often, your are better off using the chat here https://fizz.ca/en/contact-us

Chizz :))

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

1- Verify your preferred network settings is set to LTE or HSPA,
2 - make sure your data rooming is on just in case.
3 - Verify carrier setting is set to automatic

Chizz :))

Gilles
Gilles

Gilles

User level
Level
0
54 / 100
points

The settings that René suggested are ok and mobile network is on of course. Still no data.

Gilles
Gilles

Gilles

User level
Level
0
54 / 100
points

And it has been over 3 hours since I have activated the SIM card....

Make sure to choose 4G as prefered network, turn your roaming ON and choose the automatic network selection. It's all at the same place under the network settings.

MT
MT

MT

User level
Level
4
5000 / 5000
points

I noticed that several users with Samsung phone have trouble with access to data.
And in several cases the suggestion was to contact Fizz and it's unclear if Fizz could fix it or not.
So my suggestion is contact Fizz.

Gilles
Gilles

Gilles

User level
Level
0
54 / 100
points

All set to automatic with gsm/HSPA/LTE auto connect selected

Gilles
Gilles

Gilles

User level
Level
0
54 / 100
points

I was hoping that a Fizz person would pick up on my question....