Answered question

Still no 4G after Dec 7th outage?

Before the Dec 7th outage, I had 4G on my phone (although I often had to manually select the right network), but I haven't been able to get anything higher than HSPA since. After reading other comments around here, I'm starting to think that I might be alone in this?

Anghelos
Anghelos

Anghelos

User level
Level
0
23 / 100
points
Whizz
Whizz

Whizz

User level
Level
4
5000 / 5000
points
Team

Hi Anghelos,

Have you tried switching your SIM card in another device and see if you have the same problem? Also, can it be a location issue? When you go to different locations is it always 3G or does it shift to 4G at times? Also, as Tom mentioned - maybe your device does not support 4G. You can take a look here willmyphonework.net and select videotron as a carrier as Fizz is not available in the drop down yet,

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

ReneD
ReneD

ReneD

User level
Level
4
5000 / 5000
points

I guess you are right LTE is back and in good shape.
What type of phone are u using?
Double check your APN settings and that the carrier selection is set to automatic as well

Chizz :))

Anghelos
Anghelos

Anghelos

User level
Level
0
23 / 100
points

I'm using a Redmi 4X. I've read that some xiaomi devices are not compatible with some of Fizz's bands, but I'm fairly certain that mine supports band 4 (and hey, I've connected to Fizz's 4G before!) I just reset the APN settings and added Fizz's again, rebooted, and it doesn't seem like anything's changed. Still only getting H+.

(Thanks for your quick answer!)

ThomasK
ThomasK

ThomasK

User level
Level
4
5000 / 5000
points

Yesterday i got 3g only on my iPad. Today did a firmware upgrade and lte show up. Dont know if it's related. It doesn't hurt to try firmware upgrade.

I've definitely had LTE back for more than a month now. If you are on an Android device you can check whether you have somehow set it to only connect at 3G in the mobile network settings. For android 9 that's at Settings : Network and Internet : Mobile Network : Advanced : Preferred network type. The steps will be similar in earlier versions of Android but some of the words might be different. Make sure you don't have 3G selected. Any option that says LTE, 4G, or Global should work for LTE.

MT
MT

MT

User level
Level
4
5000 / 5000
points

You're probably one of the few users without 4G.

ThomasK
ThomasK

ThomasK

User level
Level
4
5000 / 5000
points

My friend has xiaomi max, same problem, only h+. It lacks the he band for LTE.

Anghelos
Anghelos

Anghelos

User level
Level
0
23 / 100
points

According to willmyphonework.net, I should be getting nothing but LTE, which is pretty inaccurate.

Before the Dec 7th debacle however, I could connect to LTE, even if only manually. Shouldn't that be an indication that my phone supports it?

I know that I never could get LTE in my apartment, so I'll re-test it in a different location when I get the chance.