Answered question

Why is my data not working

My data is not working

Honeey
Honeey

Honeey

User level
Level
0
16 / 100
points

Please follow this link:https://fizz.ca/en/faq/what-are-fizz-network-settings-apn .
If your phone is an iPhone, update to the latest iOS.
For Android phones, you may need to configure APN on your own if it doesn't do it automatically.

Fizz APN settings are:

APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl
If your phone offers you a predetermined APN type, choose “Internet + MMS”

Other fields should be filled by default; if empty, they are not mandatory

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Was it working before? Is this a new account? Are you out of the Fizz subscription zone? This could be cause be many things.
.
Have you checked your APN settings?
.
Is your account fully activated/number ported?
.
If you're out of Quebec/Ottawa, do you have a Canada wide plan? Have you activated roaming on your phone?
.
Is data toggled on on your phone?

Please follow this link:https://fizz.ca/en/faq/what-are-fizz-network-settings-apn .
If your phone is an iPhone, update to the latest iOS.
For Android phones, you may need to configure APN on your own if it doesn't do it automatically.

Fizz APN settings are:

APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl
If your phone offers you a predetermined APN type, choose “Internet + MMS”

Other fields should be filled by default; if empty, they are not mandatory.

If you use iphone, make sure you have 12.1 or above firmware.

Change your APN if you use Android.

Settings → Connections → Mobile networks → Access Point Names → APN

Fizz APN settings are:

APN: mobile.bm
MMSC: http://mms.mobile.bm
MMS proxy: mmsproxy.mobile.bm
MMS port: 80
APN type: default,mms,supl