Answered question

How come Fizz only support IOS 12.1 and above? What happen if I use old iphone 5 or 5s?

I activated other line today. It works fine with my iphone 7. When I moved sim card to iphone 5s. Data doesn't work any more. I checked and find the firmware is not 12.1 on iphone 5s. I can't upgrade it because I have only 1g left on 5s.

Why Fizz make itself not competitive with old phones. It's budget phone plan, right? So it should be compatible with budget phone such as these old iphones. Fizz will lose customers who use these old iphone.

Fizz employee, please seriously consider my suggestion.

I Feel your frustration.

Officially they only support iPhone 5s or later, because it requires iOS 12, and the 5s is the oldest model that could run it.

If you connect your phone to a computer running iTunes, you don’t need the extra free space for the upgrade.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

TrainFood
TrainFood

TrainFood

User level
Level
2
1095 / 2000
points

True now the ios 12.2.1 just came out and i have to update it.. data work fine on my other phone but not my ios 11.4.. my data wont work.. idk if i should update to 12.1 or 12.2 .ehh

I remember seeing a workaround for this in reddit, however it was a pain and not permanent. I would also like if they add support for older ios versions.

MP
MP

MP

User level
Level
2
1739 / 2000
points

I'll be getting an old iPhnoe 5 after x'mas, would be nice if I can have the option to use it on Fizz. Per specs on web, i5 can only be upgraded to iOS 10.3.3.

 

If anyone come across work around of i5 on Fizz, I'd appreciate the link, thanks in advance!

Only the iPhone 5 models numbers ending in FH19, FH1C, FH1D, FH1F, FH1G, FH1H have support for AWS, which Fizz and Wind mobile use. If your ip5 not in this list, go with other company.

MP
MP

MP

User level
Level
2
1739 / 2000
points

@Ann H., thanks!!! I won't know model# till I get the phone in my hand, already planned possible phone swop with friend's old Koodo i5 or Fido i5.

@VC, try to avoid iphone 5 if you can. I helped my senior neighbor change his iphone 5 battery twice. In the end he simply go with new iphone SE. Iphone 5 is still great phone but its batter run its course.

E
E

E

User level
Level
3
3348 / 5000
points

I think it's time to upgrade your phone - it's not 2012 anymore. You're using nearly 7 year old technology...

MP
MP

MP

User level
Level
2
1739 / 2000
points

@frederick M. and @ES., thanks for sharing info and advice!!

 

Personally I don't care for new technology, I only need/want basic functions.  I'm not very good with words  . . . . basic? minimalist? . . . . how about all the electronic waste that we create . . . . Merry Christmas to all!!!

Hello folks,

We can confirm you that the mobile data works only for iPhones 5S and Up, for iPhones 5C and lower we're are still testing to see if these older devices will work on our network.

Cheers

Ionut

Stéphane Sylvester
Stéphane Sylvester

Stéphane Sylvester

User level
Level
0
14 / 100
points

I can confirm that data and calls work on the iPhone 5S with latest iOS.