Answered question

My Data does not wor?. I have a 2 GB plan, but when turn WiFi off, iPhone will not connect.

I have a 2 GB plan, and using an Iphone 7. I did the IOS update, and under Mobile networks, it's conencted to Fizz, and LTE is displayed on top. Yet, when i turn off WiFi, the phone has no Data.

STERNA
STERNA

STERNA

User level
Level
0
0 / 100
points

On iPhones, if the Celluar Data is check off, Fizz LTE doesn't show in the top bar.
So if your phone is showing Fizz LTE, your cellular data settings is ON.

Don't forget that you can set each app on your iPhone for Cellular Data connection. So review the list of your apps you want to give access to Cell Data Network.

Also, verify under Settings / General / Information under "Operator" it has to be Fizz 34.1.

If not, 2 things to check:

1- Operator selection has to be set to automatic
2 - The operator setting update didn't worked and you might need to roll back your iOS update and do it again for it to update the carrier settings automatically.

Hope this will help

Cheers... :)

Did you find this useful ?

No (1)

Yes (0)

0%

0% of users found this answer useful

Other answers

In your iPhone settings, go to ''Cellular'' at the top then make sure ''Cellular Data'' is checked on. Below that, make sure your ''Network Selection'' is set to Auto and shows 'Fizz'.

Otherwise, you're probably best to go to ''My Profile'' on the Fizz website and select ''Contact Forms''.

Tara Le
Tara Le

Tara Le

User level
Level
0
12 / 100
points

I have the same issue. Did you find out how??